GS News - Black Ops II Won't Run on Windows XP

  • Share
    Share Video

  • Add
  • More
    Report this video as:
0 0
You have already voted for this video.
Activision details system requirements for Treyarch's new Call of Duty; game requires Windows Vista or newe...
Activision details system requirements for Treyarch's new Call of Duty; game requires Windows Vista or newer OS due to DirectX11.
Categories:
Related